With the 16.3 version release for Adobe InDesign there is native support for the new Apple M1 hardware. This native support means the performance of InDesign is increased on this platform.

We recommend upgrading to the latest Swivle InDesign Plugin (at least 4.4.0.907) when using Adobe InDesign version 16.3.

Note: Swivle InDesign Plugin 4.4.0.907 is no longer compatible with earlier versions of Adobe InDesign

Did this answer your question?